Xposed for Lollipop [Android 5.0/5.1/5.1.1]

Looking to install Xposed for your Android Lollipop?

You will need the latest Xposed Installer for Lollipop and appropriate Framework SDK for your Android device.

See How to Install Xposed Installer on Android Lollipop! for full step-by-step instructions along with video tutorial.

UPDATE: Xposed for TouchWiz Android 5.1.1 is NOW AVAILABLE! (see down below)

For Android 6.0/6.0.1 Marshmallow, please see Xposed for Marshmallow instead!

Here’s what you need:

1. Download Xposed Installer for Lollipop (for all Android 5.0, 5.0.1, 5.0.2, 5.1, 5.1.1) – Link (Check XDA here for latest version)

2. Download appropriate Xposed Framework SDK for your Android device:

Android 5.0/5.0.1/5.0.2 for AOSP ROMs/devices (e.g. Nexus 6 or Note 4 with AOSP ROM like CM12.1)

Download for ARM (most older Android devices like Nexus 4/5/6, Note 2/3/4, S2/S3/S4/S5, HTC One M7/M8) – Link (Check XDA here for latest version)

Download for ARM64 (newer 64-bit based devices like Nexus 9, LG G4, HTC One M9, Galaxy S6) – Link (Check XDA here for latest version)

Download for x86 (Intel-based devices like Zenfone 2) – Link (Check XDA here for latest version)

OR

Android 5.1/5.1.1 for AOSP ROMs/devices (e.g. Nexus 6 or Note 4 with AOSP ROM like CM12.1)

Download for ARM (most older Android devices like Nexus 4/5/6, Note 2/3/4, S2/S3/S4/S5, HTC One M7/M8) – Link (Check XDA here for latest version)

Download for ARM64 (newer 64-bit based devices like Nexus 9, LG G4, HTC One M9, Galaxy S6) – Link (Check XDA here for latest version)

Download for x86 (Intel-based devices like Zenfone 2) – Link (Check XDA here for latest version)

OR

Android 5.0/5.0.1/5.0.2/5.1.1 for TouchWiz ROMs on Samsung devices (e.g. Note 2/3/4 on custom TouchWiz ROM like BobCat ROM)

Note: You MUST BE running DEODEXED ROM, most custom ROMs are deodexed but if you are not sure, simply google “your ROM name + XDA” and read the XDA thread to see if your custom ROM is deodexed or not.  OR you can simply make a backup ROM and find out yourself.  If it doesn’t install, simply restore ROM.

Download for All Samsung Devices on 5.0/5.0.1/5.0.2 – Link (Check XDA here for latest version)

Download for Samsung Devices with Krait (Optional – This one is more optimized for Samsung devices with Snapdragon processor) – Link (Check XDA here for latest version)

Download for All Samsung Devices on 5.1.1 with 64-bit chip like Galaxy S6, Galaxy Note 5 – Link (Check XDA here for latest version)

Download for All Samsung Devices on 5.1.1 with 32-bit chip like Galaxy S5, Galaxy Note 4 – Link (Check XDA here for latest version)

3. (Optional) You can also download uninstaller which will uninstall the Framework SDK but my best suggestion is to make a backup ROM as I’ve ran into bootloop problems while uninstalling.

This is for all devices.

Download for ARM (most older Android devices like Nexus 4/5/6, Note 2/3/4, S2/S3/S4/S5, HTC One M7/M8) – Link (Check XDA here for latest version)

Download for ARM64 (newer 64-bit based devices like Nexus 9, LG G4, HTC One M9, Galaxy S6) – Link (Check XDA here for latest version)

Download for x86 (Intel-based devices like Zenfone 2) – Link (Check XDA here for latest version)

 

  • FilleDK

    what for Oneplus One?
    ARM
    or
    ARM64
    or
    x86
    ????

  • Jopix408

    What to install on Xperia Z1?

  • Aero Windwalker

    Is there even 5.1.1 version of AOSP ROMs for Samsung S6?

  • Hafiz Azmi

    I can’t install the xposed installer apk. It didn’t behave like an apk

  • Jerome Navalta

    I have a tmobile samsung galaxy note 4 SM-N910T with a darthstalker v2 rom deodexed after installing the ARM Framework SDK i get stuck on the booting process whereas the darthstalker boot img is and not turning on and off, any suggestions and help…?

  • Price William

    Max I’m want to install xposed framework on my Note SM-N900 . I’m running 5.0 odex ed stock ROM … how can I downgrade it to 4.4.2 without losing my baseband or carrier ( it’s unlocked phone ) so to easily install VN ROM or other odexed to install Xposed framework on it ? A must reply please… I’m having a bee on my bonnet to use xposed modules

  • Saurav Pradhananga

    I want xposed framework for samsung galaxy grand prime(SM-G531H). Which file I’m supposed to flash to make xposed framework work/install? ARM?

  • what for galaxy s4 cm12.1 ?
    ARM
    or
    ARM64
    or
    x86
    ????

    • greenstone

      hi did you find your answer? was looking for the same. I tried using sdk22_arm in my GS4 GT-i9505 with CM12.1 but ended up in a boot loop.

      • no i still couldnt find my answer
        im running sphl720 sprint…and ended up in bootloop as well

    • Phongpanot Phairatwetchaphan

      Galaxy S4 uses 32-bit processor ARM. So choose ARM.

  • Donald Trump ✓ᵛᵉʳᶦᶠᶦᵉᵈ ᵃᶜᶜᵒᵘᶰᵗ

    Any idea what I use for my Samsung Galaxy S5 Active SM-G870A with stock rooted ROM? I used the generic sdk and the snapdragon special one and they both factory wiped my phone.

    • joshua payne

      DID YOU EVER FIGURE IT OUT

    • TPR

      Did you find out what to download??

  • Nazir Ismail

    Hi. Can you please advice how to install xposed on Umi Hammer S on Lollipop 5.1- I have tried so many things but I get a scatter error which I dont know how to solve.
    Please advice. Thanks

  • xtrem06

    what for htc one m7 stok 5.0.2 ?
    ARM
    or
    ARM64
    or
    x86
    ????

    • Nejc

      download hardware info app to find out

  • Pulga PT

    I want xposed framework for samsung galaxy grand prime(SM-G531F). Which
    file I’m supposed to flash to make xposed framework work/install?

  • emily

    what do i download for lg g3?

  • Stevan Mihajlov

    Which one of these should I use for archidroid 5.1.1 cm 12.1 on gs3 i9300?

  • NiCo Alexsandr

    please ios rom for lg g3 okey

  • Khaoz

    which should I use for boost lg g stylo?

  • mariela preciado

    I get this message when I installed the xposed installer help me . if u know how to help me email me @ marielapzavala3@gmail.com thanxs

  • Almawsiley Alsayed

    note3 in android 5 ..ramv7 ..zip file wetch one??/pls helpe

  • Liantoni

    Xposed for Asus Zenfone 5 there is not ??

  • Joe

    Which should I use for lenovo a5000… Help me

  • Sourav Mishra

    Htc desire 816g updated to loolipop

  • Mukul Shende

    which one for moto e2 otus?

  • Melquin Juarez

    DOSE ANYONE KNOW WHAT TO DO TO GET A GALAXY EDGE 6 PLUS OUT OF BOOTLOOP I CANT FIND MY FIRMWARE ANY PLACE NOT EVEN SAMSUNG SITE SM-G928A

    • TechinJo2016

      Try just anywhere I found my stock kernel at XDA forums NOT for your phone but mine just try to find it anywhere

  • ftriplev

    Downloaded the latest versions on XDA, but does not work on my S4 with stock lollipop 5.0. Does a bootloop and stays there (waited for 35 minutes).

  • Alejo Higuera

    I’m not sure wich one I must to download, I have a Note 10.1 2014 (P600)Lollipop stock firmware rooted so?? Thanks

  • simodo

    hello I have a samsung SM-G800f (s5 mini) but with this rom G800FXXU1BOK7 – Allemagne (Android 5.1.1). It’s an official rom. What can i Download to install xposed ? The Note 4s’ version ?

  • Amar Goswami

    I want xposed framework for samsung galaxy grand prime(SM-G531f). Which
    file I’m supposed to flash to make xposed framework work/install? ARM?

    • TechinJo2016

      Same here except I need SM-G530A

  • XRetroX

    Were the version for samsung gallaxy tab 4 T535

  • Wesley Webb

    I would like to help someone but I’m needing help myself I have a 5.1.1 and the play store will not stay opened, I’ve tried everything
    I really don’t understand the framework was fine now I don’t know what to do

  • akash yadav

    I want xposed for samsung note 3 neo

  • yann caquard

    I have a “Wiko rainbow lite 4g” on 5.1.1 Is a Arm, Arm64 or 86 ?

  • beans

  • arun kashyap

    Im using stock rom samsung galaxy e5. On 5.1.1
    Which xposed file should i download?

  • GokuTheReal

    I have an Samsung Galaxy S6 5.1.1 rooted with TWRP… i installed nothing else… which version do i have?? the touchwiz Rom or the AOSP ? which file should i download ? 🙁 pls help me. the last time i tried this, my phone went to a bootloop and i fucked everything up and i needed to install the whole firmware new.

  • Trent Merryweather

    Which sdk should I use for Samsung Galaxy S4’s Aurora I9500 Note4 S6 Port No.6.1 V8.5?

  • Abd Vool

    i have note 3 sm-n900 lollipop 5.0 which one should i download in sdk21 arm ??? they have alot of xposed v72 to v86 …. and before i downloaded the last one and i got problem stuck on boot so which one should me download … or it’s not work for note 3 n900 ?

  • fazui

    I’m xperia m5 with loli 5.1. Which one should i download?

  • Vimal Cv

    Which SDK version should I use in my infocus m350 with android 5.1 lollipop??

  • Azim

    Hi. Im confused with all the thread.
    I js need to know a few things if you dont mind:
    1- can i install xposed to my s5 lollipop 5.0 in its original touchwizz rom?
    2- if i cant do that, is the resurrection remix custom rom is a deodex rom?

    Sorry. My head is spinning from reading about root, flash, open recovery and etc. So i js need a brief advice if it’s not too much to ask. Thank you.

    • ba rangga

      YUP ME TOO!!! Hope he will answer it, or at least someone share their knowledge with us

  • Kevin Claessens

    hey, could you find some time to help me out with the pokémon go?
    i have the joystick, mocklocation app and xposed 2.5 but the latest version of xposed ain’t active.. do you see the problm?
    Grzt from BELGIUM aka KzoekAMBRAS

    Wiko pulp4g 5.1.1
    UBUNTU 14.04

  • ronilucifier

    xposed working on sm-n9005 ? if yes can u provide details which rom and files. i tried but stuck in bootloader

  • Kyle

    Got the Samsung Galaxy S5 Mini G800F and trying to use the sdk 22 v 86 but always stuck in a bootloop. help pls

  • Ninaad Majumdar

    which should i take for zenfone 2 ze550ml
    i have only unlocked the bootloader and flashed twrp

  • Ulises Solis

    Which one should i use for my LG k7?

  • Boundizt Suryawan

    my device (AArch64) Instruction sets armeabi-v7a. which the xposed will work in samsung j7 with instruction like that?

  • Jonathan Canuelas

    ¡Please! HELP!!!! 🙁
    I want to install frameworks on LG Gpad X 10.1

    but i dont know how.

    I will apreciate some one s Help. 🙁

  • Hartanto Hadi Setiawan

    My device is Sony experia z3. Which one i must install? For pokemon go acctually. Thx

  • Noid C Arocha

    Okay I’ve been stuck about for 2 days now halfway through all of this I am running a Samsung Galaxy Grand Prime with a 32-bit to 64-bit running lollipop 5.1.1 I need help finding what ARM file i need

  • ganesh

    where can i find framework for lollipop 5.0 touchwiz ODEXED Rom

  • Srikanth Nayak

    hi
    i am using Sony Xperia E3 D2212, i want to install Android 5 or 6 on my phone pls help me

  • ismi abbas

    can i install android 5.0 on vivo.

  • Gurvir Singh

    If you can just letme know
    What if I am on a stock ROM i.e I have recently flashed a stock ROM on my Samsung Note3 Neo N750 (3G)
    And I want to Install this Xposed thing
    can I do that !! , Please help me with this I’ve been wandering here and there for this answer

  • gtpl sibsagar

    I HAVE OBI SF1.I NEED XPOSED FOR MY PHONE.CAN ANYBODY HELP ME?IT RUN OS 5.0.2 AND I HAVE TRIED ALL 5.0 XPOSED BUT DIDNOT WORK.I ALSO TRIED MANNUALY.MY PHONE IS ROOTED.BUT FLASHIFY DOES NOT WORK.HELP?

  • ravinder brar

    i have samsung galaxy s4 i337m with loliipop 5.0.1 with albe95.lollirom.9.0.i9505xxuhpa1 please guide me how i can install xposed framework or is it a deodex rom?

  • GreyWolf

    I have a lg tribute 5 that is rooted with su. I’ve been flashing with flashfire but the framework wont be applied for xposed. Please help.

  • mangal

    not working for Galaxy Sm-g600fy